PopOs, Gnome 3 and Snap - Aether is clickable but does not run

So far I have had the same issues on 2 units — both of which are using PopOs and Gnome 3.

Snap package was working fine a few weeks ago.

Now, when I go to run Aether from the menu, it will let me click the icon and then look like it’s starting up but nothing happens. No icon appears in the taskbar and no window from the program populates.

I have also tried to run the application from terminal. I will type “aether” in the prompt, and then it will just drop me to a new prompt right underneath the first command without opening anything.

I have tried uninstalling the snap, clearing out all file and trying again, but that doesn’t solve the issue either.

1 Like

Also — Would there be any interest in packaging Aether as an AppImage or Flatpak in future releases?

I wrote about Snap / other packagers before: Aether on Linux Mint 20

In short, we’re definitely moving off Snap, but not sure what to. Still evaluating options. Mint removing Snap was the last stone that made the whole cart roll over.

That sounds like a Snap issue, but I’m unclear why — nothing has changed in the past few weeks. Are you running from the console with the --dangerous flag?

Yes. Installed it with --dangerous flag. It used to work great for the longest time. Then something updated and shit got real fucky.

Can’t wait till I figure out what is going on with it so I can actually be bank on Aether and start using it again!

I use Pop and Arch so I vote for deb and AUR :smiley:

With the new release, Aether is now available as a .deb. Here’s the changelog and here’s the link for all the versions we now release: link. Mind that AppImage version does not work for now — that is there in the case anybody wants to help debug it.

I get the symptoms described in OP after installing from .deb – menu launcher and /usr/bin/AetherP2P do nothing.

I had previously purged all things snap.

It might be worth looking at Sandstorm, if other options aren’t working out too well:

I’m having the same issue with the deb. If I run it from the terminal:


It runs fine. Zero issue. If I try to launch it from GNOME I get this:

Screenshot from 2021-01-10 18-42-49

Are you on Pop OS, and if so, what version of GNOME and Pop OS do you have? I’m trying to isolate what causes this, GNOME or Pop OS or some particular version combination of the two.

1 Like

Ah yes! That would have been helpful :slight_smile:

HP EliteBook 840, Intel x64, Pop 20.10, Gnome 3.38, X11.

Cool, I don’t have access to Pop OS, so I’ll try with GNOME on Ubuntu, trying to get as close to the version you have as possible. If it works in Ubuntu (I think it does — that’s where I check things working) then we know it’s a Pop OS issue and then drill down from there further.

1 Like

Should be a very close approximation of the environment. I’m a writer, so I don’t have a ton of stuff installed or lots of advanced configurations flying to and fro. Hope that helps! Thanks for just being here!

1 Like

I’m so sorry, and old, and admittedly a little addled. I had installed the snap. Grr. I’ve removed it an installed the deb. Checking, will let you know.

New, and already causing trouble!

Checked and working just fine. I apologize if I added any frustration to your day. I should have been more thorough.

For some more context, so this debacle is hopefully helpful, I had installed snapd on Pop to have access to a few apps that have gone snap-only. I just ran the basic apt install with no other config. The error I was getting was with the snap. I’m not sure it will run the same in Ubuntu’s snap environment.