Not connected to the network (I think?)

Hi, I just discovered Aether yesterday through Scuttlebutt. I’ve been clicking around for a few hours and I must say I’m very impressed! Did you really build this all on your own, Burak? If so, that’s amazing!

Anyway, I was a bit surprised by how little activity it seemed to be on there, I get that it’s fairly new and that there’s some friction having to install an app and all, but still. I’m not sure if it’s actually little activity, or if I’m just not connecting to the network properly. I got a friend to join and we can’t find each other so something seem to not be right. It would make more sense if I couldn’t see any subs at all, but I can.

My backend is yellow and inbound and outbound conns. are showing 0, I’ve seen outbound showing 1 sometimes though. I’m guessing this is the problem? Unfortunately I can’t open any ports where I’m renting at the moment so I can’t test that until I move in about 8 weeks.

Some other issues I’ve encounter is that when I try to quit Aether it doesn’t shut down properly, it’s doing something in the background. If I try to re-open it, nothing happens. I have to manually kill it and then it opens fine again.

I also tried to bring my frontend_config.json to another machine. This resulted in endless loading at start up. Deleting the .json solved it, but then it obviously opened as the default first time startup. I started a new thread on one machine and tried to find it on another after an hour or so, but no luck.

A bit of a shame as I really like this and would like to start using it (and possibly become a supporter), but I guess I’ll try again in about 8 weeks if there’s no other way around this issue right now? :crossed_fingers:

Lastly, I think this should have official Linux support! I get that the Linux userbase is small and that it’s probably a bit of a pain with all the different distros and stuff, but being a FOSS platform it makes sense to officially support a FOSS OS. I also feel like Linux users might be more interested in this than the average person so even though we’re few and far between, we might make up a significant % of the Aether userbase?

Other than the issues, I love it! I’ll definitely keep an eye on the development going forward, keep up the good work! :slightly_smiling_face:

  • Operating System: Linux Pop!_OS 19.04 x86_64
  • App version: Aether Community Edition v2.0.0-dev.13, build 1906191901.7eaf250

Hey hey,

Thanks for checking it out! Big fan of Scuttlebutt over here :slightly_smiling_face: I didn’t know they had Aether in their docs, but it’s great to see. And yes, this is my work so far, but if there are any takers on collaborating, that’d be super cool. (wink wink)

There really isn’t much activity to speak of nowadays, so you’re correct on that one. The other thing is, the existing nodes in the network prefer older nodes because whenever we get a user spike, we had the trouble that a flood of new nodes would come in, add themselves to the routing tables, and then pretty much immediately log out (which is fine, they were just looking around after all), but then that causes problems with remaining nodes being able to find each other, since they cause the routing table to have a lot of thrash by joining and exiting en masse. To prevent that, the existing nodes will largely hold on to the peers they know and they will moderate the incorporation of new peers to their ‘neighbourhood’, so that they will continue to remain connected and able to deliver even in the cases of rapid in and outflows of new nodes. Out of every 10 connections, only 1 is made to a new node, the remaining 9 is made to nodes known prior.

Unfortunately, the side effect of this is the effect you’re realising, you have to keep the app online for a couple hours to a day or two for it to be able to start delivering content outwards, because that’s generally how long a remote node takes to be ‘convinced’ that you’re around for long enough to be viable. So yes, not much of an activity, but also that you guys are new.

Some other issues I’ve encounter is that when I try to quit Aether it doesn’t shut down properly, it’s doing something in the background. If I try to re-open it, nothing happens. I have to manually kill it and then it opens fine again.

This also ties nicely with the Linux support so I’ll address them both here. This is pretty much exactly the reason Linux is ‘officially’ unsupported. As you know Linux is not one thing, but hundreds, thousands of things, and it’s not even really possible to even ‘officially’ support Linux since you can’t possibly try all distros. What I do instead is that I make sure it works in Ubuntu, and Ubuntu-like distros. Meaning, those are practically officially supported and covered. But I can’t really say I cover Linux when I actually mean Ubuntu / Debian, so that’s where the ‘not officially supported’ comes from.

Also, as you mentioned, Linux userbase is small — from what I can see, it’s about 2%, and 1.75% of that is Ubuntu / Debian. From a pragmatic perspective, 2% doesn’t even justify having Linux builds, but I do it and spend time debugging it because I like Linux. It’s also that Linux users are generally savvier than others and they can usually figure out their own problems, so I don’t think ‘not officially supported on Linux’ stops anybody.

For the problem(s) you’re having, I think you have a fairly rare distro, and the problem you’re having does indicate that as well. Unfortunately I can’t really help you with that since I know nothing about your distro, there are a lot of things that can be going wrong. Generally, using snap on distros who don’t come with Snap by default tend to cause these kind of problems since lots of things rely on that interface fairly implicitly, and that’s what I debug against. I do test with Ubuntu practically every day for my development purposes, so I know that for Ubuntu, everything works as it should.

I think Linux support is going to get only better from this point on since I started to actively test for it, but we’ll see. :slightly_smiling_face:

1 Like

Thanks for the detailed reply. If I knew anything about code, I’d help :innocent:

A lot of projects officially supports Ubuntu / Debian and others unofficially. From a marketing standpoint I think that’s better than saying no official support for Linux overall.

So the Linux userbase of Aether basically reflects reality, I would’ve thought it’d be a bit higher. I appreaciate the Linux support though, official or not! :smiley:

Pop!_OS is basically Ubuntu, every other Ubuntu thing has been running fine right out of the box for the year I’ve been using it. Aether might be different of course, but I doubt the distro is the problem.

When you say I have to keep the app online for a couple hours to a day or two, is that consecutively, or in total? I usually put my computer to sleep when going to bed, but maybe I should leave it running during the night to see if that helps. I’ve had it open for about half the day already, I haven’t lost hope yet! :upside_down_face:

If not, I can try after moving to the new place. What I don’t understand is that I can see many communities, if I couldn’t connect to any nodes, wouldn’t everything just be blank? Or does the app ship with some content by default or something?

Anyway, I’ll tell all my Linux friends to make your Linux efforts more justified :stuck_out_tongue:

:slight_smile:

By the way, I noticed your (I think it’s you?) posts have started to come though.

1 Like

You’re right, wooo! Well, that’s something that can be improved upon because that took forever! :stuck_out_tongue:

It’s probably my friend’s posts you’re seeing. I tried to post something on another install that I’ve now abandoned so that never went through. I’ll start to post things now though!

I’m @MHx ( because MH was too short :unamused: )

When I move to another connection, does this process happen again, or is my account already accepted by the nodes to be viable even if I connect from another place?

It’s based on the IP so it might happen, but it would be shorter, I think. As an example, I change IPs constantly between work and home, and it continues to work fine.