No content loading on initial startup

  • Operating System (Platform and Version): Windows 10
  • App version: Aether v2.0.0-dev.5, build 1811030036.53a6bb49

After going through the initial bootstrapping process no content is loaded. Occasionally a loading animation will appear, but nothing is loaded once it disappears. I left the program open for several hours, but that did not change anything.

On the status screen all categories are green except for Network, which is marked yellow. It appears that I can’t connect to any nodes. Is this just due to the network I am currently on?

Inbounds conns. in last 15m: 0
Last inbound: Unknown
Outbound conns. in last 15m: 0
Last outbound: Unknown
Last outbound duration: Unknown
Your node port: 50378
Port mapping status: Mapping failed, no router, or router uncooperative

Can you try again? There is enough demand that I’m having a little hard time keeping the bootstrap server up. Once you’re inside (past the bootstrap stage) you it doesn’t matter, bootstrap is a one-use, first entry thing.

Uninstalling and reinstalling appears to have fixed it.

1 Like

Same issue, but uninstalling and reinstalling didn’t fix it. Also opened the port and forwarded it to my PC, but still nothing

1 Like

Bootstrap server is having hard time dealing with the demand, especially when it happens when I’m sleeping (I’m on Pacific Time).

I’ll scale up the server in an hour or so. I’ll write here again when you should try again.

It just synced. Just needed a little more patience I guess :wink:
Thanks for the quick reply!

Awesome : ) I’m completely floored by demand there is for this. It’s as if we were all thinking the same thing, but nobody said anything about it until now.

Apologies for the interruptions while I’m trying to improve the service availability as fast as possible. You all dealing and finding ways around these issues are the thing that’s going to make the guys that come after you have just that much better experience.

This is just 12.01am on a new day y’all. Let me work through this, and it’ll all be better.

I’ve pushed some code to make servers more stable, so from this point on, this should improve this no content loading on initial startup issue. Let me know if anyone has any more trouble.

Is there any way you could get community members to help with hosting the bootstrap? I’m not sure how it is managed, but I’m sure a lot of us would be willing to assist with some bandwidth.

1 Like

There are — the bootstrap server is the same server that runs as part of the client app, it’s just setting a bit in the config file so that it acts as a bootstrap server. I’ll release the server (backend-only) builds that you can put up in a VPS, or run at home.

However, bootstrapping a lot of people takes a significant amount of resources, so I don’t think there are many people in the community willing to keep that kind of highly trafficked server up yet — it takes a decent amount of Linux sysadmin skills.

I think when the community matures a bit, that could become a real possibility. There is certainly no reason that other people can’t run bootstrap nodes, there is nothing specific to me that makes me uniquely capable of running bootstrap nodes.

The same on Win 7/i386 (cleaned, restarted, un-firewalled, etc). So, there is a bootstrap server at work, and in fact don’t works quite okay for now. … I’m curious to see the architecture of this p2p protocol in form of annotated graphics… Just as curiosity. I will not use the app trough, because of the “impeachment” stuff.

initial bootstrap doesn’t seem to load content. re-installed, changed networks, restarted application and still no dice. port mapping is showing as failed. it’s been running for over 24 hours.

Port mapping isn’t required — Aether can function with it. I can confirm network is functional, there have been few posts in the past hour as well. It’s possible that you might be on a restrictive network.

I would recommend following these:

Let me know if this solves it. If not, we can try to debug further.

thanks! that seemed to work, as it now says “Catching up: Downloading fresh content from Aether…”