Browse Communities Constant Loading

  • Operating System (Platform and Version): Win 10
  • App version (at Preferences > About): v2.0.0-dev.5

Expected Behavior
I expected a list of all communities to be brought up when trying to browse communities.

Actual behavior
Nothing ever loads onto the browse communities - all screen, just an infinite loading circle.

To Reproduce
Happens every time.

Additional Information
First time using Aether so I’m not sure if there is some setting I need to change.

Thank you,

*Edit: I went into my backend file and changed the externalIp config to my public IP address and it worked. This should probably have some kind of documentation in the setup process.

1 Like

Oh very interesting. Yeah, the external IP thing is behaving erratically with some few people. It’s on my list of things to take a look at.

Same problem on initial install. I get Popular posts, but no Communities load. (OSX Mojave)

Oh that’s a little weird, you’d expect it to either not work (nothing loads) or both popular and communities work. Is it just spinning? Did you try restarting your app (full close, wait 10 seconds, then restart)? If nothing happens, you can delete the user profile (Win: C:/AppData, Mac: ~/Application Support/Air Labs, Linux: ~/.config/Air Labs), and reopen the app. That should get you back to the blank slate, and from that point on you can try again. Let me know if the issue persists or this fixes that.

I did what you said, but still have the same problem. I can get Popular, and even upvote posts, but no Communities. Just a spinning icon. :frowning:

Let’s do this: can you send me the whole zipped ‘Air Labs’ folder from the location I mentioned above, so I can grab your user profile, put it into my app, and see what goes wrong? I think this is pretty much the only way we can replicate this. I’ll PM you an address to send it to in a moment.

I have the exact same problem. Tried reinstalling that did not help.
It seems to be a firewall issue.

I just had a chance to try the profile files @crozilla sent me. Funny enough, the profile works perfectly for me on OS X Mojave. The database is fully intact as well, I can’t see anything that’s obviously wrong. I can navigate to the communities too.

You might want to follow these instructions to just delete your profile and start from scratch, and that should probably fix it. If you guys encounter this problem again after following these instructions, definitely let me know.

Deleted the folder and reinstalled the app, everything works as before—not right. I think it must have something to do with my router not mapping (see screengrab). Sound right? Or might it be something else?

Oh wow, very interesting. I’ll compile you a special build that can make the error message visible and send you the link.

So just to update everyone here, I sent a new build to crozilla and it doesn’t happen on the new build so far. I don’t exactly know what changed, so it might be a fluke, but it seems to have fixed the problem for the time being.

I’m also having the same issues. I’ve tried all the fixes reported in this thread (except the new build) and I still can’t load communities either.

Download the app again from the website, I just made the new version available publicly. If that has the same issue, great - and I’ll give you instructions to get the error message so I can fix this.

I’m actually very new to Aether and downloaded it earlier today (4pm Eastern Time). When I go to download, it appears to be the same build.

Is it dev.5 or dev.6? If dev.6, you should follow these instructions and copy / paste the error message found so we can debug this further.

Instructions here:

It looks like dev6. Here’s the full filename:


As for errors, I get quite a bit of this:

Full text below:

vue.js:596 [Vue warn]: Error in callback for watcher "function () { return getter(this$1.state, this$1.getters); 
}": "TypeError: mixpanelInstance.get_distinct_id is not a function"

(found in <Root>)
warn @ vue.js:596
vue.js:1742 TypeError: mixpanelInstance.get_distinct_id is not a function
at Object.module.SendRaw (metrics.ts:64)
at Vue.eval (index.ts:40)
at (vue.js:3230)
at flushSchedulerQueue (vue.js:2980)
at Array.eval (vue.js:1838)
at MessagePort.flushCallbacks (vue.js:1759)
logError @ vue.js:1742

This is very helpful, thank you! Which OS do you use? I’ll make you a new build and send your way via PM.

You’re quick! I use Windows 10, Home edition, 64 bit. Currently on version 1803 (pre October update, I think).


Just sent you a debug build. Let’s see what happens.

Update: the debug built I sent fixed the issue. I’m bundling the bugfix into the release version.