Aether Flagged as Proprietary when installing .deb

  • Ubuntu 20.04.1 Focal
  • App version (at Preferences > About)

Expected Behavior
The Ubuntu installer indicates Aether is Free.

Actual behavior
The Ubuntu installer mistakenly indicates Aether is Proprietary

To Reproduce
Download the Aether .deb and attempt to install it on Ubuntu

Additional Information
Aether is not the only Free software with this problem.

[ Thank you! ]

Free as in beer vs. Free as in open source and shareable code.

I’ve noticed this as well before shipping the .deb version. My understanding is this is the reason why it happens:

  1. .deb is the Debian format, which Ubuntu happens to use. Ubuntu also has its own software center app. That app also acts as a .deb installer.

  2. The apps downloaded from the software centre natively through their centralised service don’t seem to be .debs, they have extra metadata that Debian does not support (?).

  3. … And license information is one of the extra metadata fields the Ubuntu software centre can’t read from deb files, but it can from its own native packages from its own centralised server.

  4. This means any .deb file that you might be able to install will always say ‘proprietary’ because that is what the ubuntu software centre defaults to when it cannot read any licence information from the package. At least this is my best guess.

  5. Similarly, downloaded .deb files cannot have screenshots and a bunch of other stuff that USC native packages can have, so it seems license information is not the only thing Ubuntu only reads from its own Ubuntu-hosted packages, and not from any other source.

Basically, not much we can do - the license info is there, you should just ignore it since it’s never going to be reliable due to very few packages USC can read it from.

1 Like

Thanks! We should mark this [SOLVED]

We don’t have a [SOLVED] flag here but a post saying it’s solved is good enough for search purposes. Actually, I’ll take a look at how Discourse works, perhaps there’s a way to create flags of that sort…

Thanks. I think we used to be able to edit the title of our posts on this forum, but that option seems to be unavailable now.