Aether activity?

I’ve been off for a few months but started my Aether again yesterday. Noticed though I was not getting any newer posts that Sept 2021. I’ve ripped by config apart, tried a fresh profile, deleted everything and re-installed and fully fresh copy with zero files under ~/.config. Keeps only building to Sep '21.

Now I’m also seeing only post topics here dated up to Sept '21 which is pretty odd. Did I miss something since Sept '21? Maybe it’s not me?

1 Like

Hi, @danie Welcome back to Aether, and thanks for your post.
I can confirm it is not just you. Incoming connections seem to be unavailable. @b has been deliberately keeping quiet lately, but should be back talking with us again shortly.

Can anybody else replicate this?

1 Like

I asked the same thing, but no one approved my post… seems to be a dead project

1 Like

Hi all — Danie and Highland, thanks for confirming. On my own node it seems to be working (as in, I have posts from recent past) but it is possible because I’ve always kept my node running in the background so I might have better # of peers than most.

It’s possible that the bootstrap node has run out of space or something of that sort, and that might have been preventing new users from grabbing new data after a specific point in time. I’ll take a look this Monday and figure out whether that is the case.

As for keeping quiet, it’s because I’m looking for a full time job for myself. So the last few months have been all interviews and not much time to do anything except interview prep. Once I nail that down I should be able to get back to being more active. Wish me luck y’all. :slightly_smiling_face:

2 Likes

Ah b thanks for confirming. I did post 3 posts on 6 Feb, but they may have not got through without the peer connections, and yes maybe the ones I was connected to are no longer there. Mine is not a new user, but it may have lost it’s peers. OK will check again after Monday.

Good luck with the job hunting!

Thanks, @b
The job market must be ecstatic you are looking again.

https://www.llnl.gov/join-our-team/careers/find-your-job/0d659855-5fe3-49dd-a1c7-e75f07f64bb9_mid-senior-level_associate_director_livermore_computing

Thanks for reporting the issue, @yungkingsley.

Aether is a funny place. You could say it is going through a Dark Age, at the moment. :smile:

Hi, @b Any progress on this?

Been running mine every day now but still seems stuck at 2 Sep 2021 as the last New posts.

Yup — my apologies, my job interviews were supposed to end the end of last week, but they spilled into this week as well. I’ve narrowed the problem down to Cloudflare in the meanwhile, which sits in front of the bootstrap node and acts as a cache. It seems that bootstrap node (i.e. the Aether code) is working fine but Cloudflare is holding on to some old copies instead of updating — it is possible that they have made some API changes and cache clearing calls are no longer working.

I need to debug this further. Good news is that I’m almost done with these day-job interviews so I’ll be free very soon.

1 Like

same here
i did not receive any message since September 2021
in any device

Hmmm, Aether seems like the perfect place to host a little community. I just wish it had a working iPhone app and didn’t have some of the issues listed above. I’m currently using Discourse for my community and it works really well, but I could see Aether coming in handy too!

Overall, awesome project!

Looking forward to more updates! I’ll be keeping my eye on it for sure!

ohh its great to chat with all of you

Thanks that makes sense as Cloudflare can do weird things in the background with caching etc. OK will wait rather until you post an update here, so we’ll wait until after the interviews are done. Hope taht goes well.

That’s unfortunate. Here goes the 6 months content life time :confused:
About time someone reporting on this major issue. Thank you @danie

Thank you @b

@HighlandGNU Nice to see you around :slight_smile:

1 Like

Cloudflare is proven an internet chokepoint again, just as war in Europe commences…

Hi, @danrobi ! I hope you are doing well.

I tried reporting it months ago, but forum moderators never approved my post.

Hi all,

I spent some time debugging this and long story short, I think my intuition re: Cloudflare was correct and it works now. I might do a larger writeup about this later since this is quite interesting, but the gist is, there are two options:

a) If you’re just joining Aether or have had issues before, you should be able to just delete your local DB to reset your local app [1], which should immediately pull in the entire network.

b) If you are running it already as an existing user with data and you don’t want to do anything, when your node hits bootstrapper node next time, the new data should fill in, usually within 6 hours or so. No action needed on your part.

Another interesting thing to note is that this was an inadvertent worst-case test where bootstrap server was gone for 6 months, with the network completely off-grid, no infrastructure, not even a bootstrap node to help out.

Theoretically what should happen is that the network, for the participants already joined, would continue to work, but new entrants would have to find an active node’s IP to manually bootstrap from. I’m happy to say at least the theory was correct, and the network did pass the acid test of being functional for existing, ongoing users without any bootstrap server at all. For example, the app was working fine for me, I was communicating with people just fine. (That’s probably why it took a bit of time for me to notice this, as well.)

New users or long-time-away users weren’t able to rejoin the swarm (since bootstrap server is the convenient catcher-up) but that is also predicted by the initial theory, since the point of the bootstrap server is to avoid asking new or long-time-away users to find an active node to jump in themselves.

My main worry with Aether’s networking code was that it was implicitly too reliant on bootstrap node being alive all the time, and that most posts traversed through bootstrap node and then jumped to others, instead of spreading at a peer-to-peer fashion. If anything good has come out of this, we now know that this is not true, for existing users the network does just fine without a bootstrap. This was a test that I wouldn’t have the stomach to do on my own for any real amount of time myself so this is very useful real-world data, and it makes me more confident that Aether can scale when the time comes.

[1] Instructions here, but instead of deleting the entire Air Labs folder, go into backend and delete AetherDB.db a minute after the app is fully shut down.

2 Likes

Great thanks @b and as you say now we know a lot more about how it works with the bootstrap node not present. Also shows again with P2P we need to keep it active daily or regularly. Going to let mine run 6+ hours now and see if I can pick up peers again. Thanks for the diagnosis and feedback.

1 Like